Lehigh Campus Blue Light Emergency Phone Experiencing Issues

Resolved

Emergency blue light phone issues have been resolved.
Posted Apr 21, 2025 - 16:02 EDT

Investigating

Lehigh campus blue light emergency phones are experience technical issues. LTS is working to get these issues resolved and will provide updates.

Campus Safety Communications remain operational. HawkWatch and cell phones can be used to contact Campus Safety at 610-758-4200.
Posted Apr 21, 2025 - 09:02 EDT
This incident affected: Communication & Collaboration Services.