Banner Unavailable

Resolved

Ellucian has restored connectivity to Banner, and all associated services and integrations are now back online. Systems are stable, and we’ll continue to monitor to ensure full functionality.

If you experience any issues, please contact the LTS Help Desk at (610) 758-4357 or helpdesk@lehigh.edu
Posted Nov 04, 2025 - 17:56 EST

Investigating

Banner AppNav (Admin), Self-Service Banner, Banner database, and related integrations are currently unavailable. We received alerts indicating interrupted connections and have submitted a priority 1 ticket with Ellucian support. We're working to restore service as soon as possible. We will provide updates as more information becomes available.
Posted Nov 04, 2025 - 17:18 EST
This incident affected: Software.