A fix has been implemented and we are monitoring the results.
If you continue to experience issues booting your computer, please submit a help ticket at go.lehigh.edu/comp, call the LTS Help Desk at (610) 758-4357, or email helpdesk@lehigh.edu.
Posted Jul 10, 2025 - 16:30 EDT
Investigating
At approximately 8:00 a.m. today, July 9, Library and Technology Services (LTS) began receiving reports of long delays (of up to 45 minutes) in booting up Windows systems on campus. It appears that once the reboot completes, the system is stable, so our recommendation at this point is to wait until the boot completes.
If the slowness does not resolve, please submit a help ticket at go.lehigh.edu/comp.
We are actively investigating the issue and will provide updates on the LTS Status page as more information becomes available.
For questions or assistance, please email the LTS Help Desk at helpdesk@lehigh.edu.
Posted Jul 09, 2025 - 10:09 EDT
This incident affects: Computing & Infrastructure Services.