Banner Unavailable for Scheduled Maintenance, Friday 8PM - Saturday 12PM

Resolved

Banner maintenance has been completed. If you have any questions or run into any issues, please contact the LTS Help Desk at (610) 758-4357 or email at helpdesk@lehigh.edu.
Posted Jun 21, 2025 - 11:51 EDT

Identified

Banner will be unavailable for scheduled maintenance and upgrades beginning tonight Friday, June 20th at 8:00 p.m. to approximately 12:00 p.m., Saturday, June 21st. To read more about the scheduled maintenance and what services are affected, please visit LTS News: https://lts.lehigh.edu/news/banner-unavailable-8-pm-fri-jun-20-12pm-sat-jun-21. Check the LTS Alerts page: https://lehigh.statuspage.io/ for any updates in the event that this timeframe is altered.
Posted Jun 20, 2025 - 20:00 EDT
This incident affected: Software.