Email delivery issue affecting messages from outside Lehigh

Resolved

Google has resolved the issue. More information on the Google Gmail issue can be found at https://www.google.com/appsstatus/dashboard/incidents/NNnDkY9CJ36annsfytjQ
Posted Jan 25, 2026 - 08:54 EST

Investigating

At approximately 7:00 a.m. today, Library and Technology Services began receiving reports that users are not receiving email sent to lehigh.edu accounts from outside the Lehigh domain. Email between Lehigh users appears to be working normally.

LTS is actively investigating this issue and will provide updates on the LTS Status page as more information becomes available.

For questions or assistance, please email the LTS Help Desk at helpdesk@lehigh.edu.

Sincerely,
Library and Technology Services
Posted Jan 24, 2026 - 10:42 EST
This incident affected: Communication & Collaboration Services and Google (Google Apps Gmail).