SSL Certificate Maintenance in Ellucian Cloud Environment
Completed
The scheduled maintenance has been completed.
Posted Apr 29, 2024 - 06:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 29, 2024 - 01:00 EDT
Scheduled
Ellucian will be applying a new SSL certificate to Lehigh's production Ellucian cloud environment on Monday, 4/29 between 1AM-6AM. A temporary downtime will be experienced while the new certificate for single sign-on (SSO) is being applied. Affected applications and integrations include: Connect Lehigh (on the Ellucian Experience platform), Ellucian Workflow, and the eBill Suite (TouchNet integration).
Posted Apr 27, 2024 - 12:06 EDT